Flash on FF4

After the upgrade my flash player has gone bonkers. The add-on that fixed it for me was Flash-aid 2.0.6 that resolves conflicting installations.

Hurray for the Firefox Community!

Here is the script generated by the add-on that resolved my issue:

#!/bin/bash

cd "/home/gladys/.mozilla/firefox/fcnqxf1m.Tek4P/extensions/flashaid@lovinglinux.megabyet.net/chrome/content/tmp" && rm -f flashplayer32* && wget http://www.webgapps.org/downloads/flash/beta/flashplayer32 && tar xvf flashplayer32 && sudo chown root:root libflashplayer.so && sudo chmod 0644 libflashplayer.so && sudo mv libflashplayer.so /usr/lib/mozilla/plugins/ && rm -f flashplayer32* && sudo ln -s /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/libflashplayer.so
sudo mkdir /etc/adobe
sudo touch /etc/adobe/mms.cfg
TWEAK=$(cat /etc/adobe/mms.cfg | grep 'OverrideGPUValidation')
if test -z "${TWEAK}";then
echo 'OverrideGPUValidation=true' | sudo tee -a /etc/adobe/mms.cfg
fi
cat /etc/adobe/mms.cfg | sed '/EnableLinuxHWVideoDecode=1/d' | sudo tee /etc/adobe/mms.cfg
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s